summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian/rules.in
diff options
context:
space:
mode:
authorKonstantin Pavlov <thresh@nginx.com>2024-12-19 10:23:57 -0800
committerKonstantin Pavlov <thresh@nginx.com>2024-12-19 10:23:57 -0800
commitd8acad350a52a20918c46c09cb0a0f5479400923 (patch)
tree7d9c4b64daa60d3ac121743dfa3735c6fc5687a4 /pkg/deb/debian/rules.in
parent624debcf17ea7faab01fa841bd4dcd9f308cf306 (diff)
parent27bde184dedcbf687db2f314c60c037623318a8d (diff)
downloadunit-d8acad350a52a20918c46c09cb0a0f5479400923.tar.gz
unit-d8acad350a52a20918c46c09cb0a0f5479400923.tar.bz2
Merge tag '1.34.0' into packaging1.34.0-1
Unit 1.34.0 release.
Diffstat (limited to 'pkg/deb/debian/rules.in')
-rw-r--r--pkg/deb/debian/rules.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index dd75b562..d43da2de 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -79,7 +79,7 @@ configure.unit_debug: config.env.unit_debug
build-arch.%: configure.%
dh_testdir
- $(MAKE) -C $(BUILDDIR_$*)
+ $(MAKE) -C $(BUILDDIR_$*) E=0
$(MAKE) -C $(BUILDDIR_$*) build/lib/libunit.a
ifeq ($(DOTESTS), 1)
$(MAKE) -C $(BUILDDIR_$*) tests
@@ -121,7 +121,7 @@ install: build do.tests
dh_installsystemd -punit --name=unit unit.service
dh_installsystemd -punit --name=unit-debug --no-start --no-enable unit-debug.service
dh_installlogrotate
- cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR) make install
+ cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR) make install E=0
cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR_dev) make libunit-install
install -m 755 $(BUILDDIR_unit)/tools/unitc $(INSTALLDIR)/usr/bin/unitc
install -m 755 $(BUILDDIR_unit)/tools/setup-unit $(INSTALLDIR)/usr/bin/setup-unit