summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian
diff options
context:
space:
mode:
authorAndrei Belov <defan@nginx.com>2021-11-18 17:04:04 +0300
committerAndrei Belov <defan@nginx.com>2021-11-18 17:04:04 +0300
commitb400ccd1aa8eeb6a5de1707e0bb8c3d417fe69b7 (patch)
tree60ff49ffc16ef7cb3aad1beb2d78f051a8794cdf /pkg/deb/debian
parentfafd44166d9e835e91a4c5668048308ce99a62bd (diff)
parentb77895d1c7d6cd4826ac7427c91baa95b998a912 (diff)
downloadunit-b400ccd1aa8eeb6a5de1707e0bb8c3d417fe69b7.tar.gz
unit-b400ccd1aa8eeb6a5de1707e0bb8c3d417fe69b7.tar.bz2
Merged with the default branch.1.26.0-1
Diffstat (limited to '')
-rw-r--r--pkg/deb/debian.module/unit.example-jsc18-config15
-rw-r--r--pkg/deb/debian.module/unit.example-python3.10-config16
-rw-r--r--pkg/deb/debian/rules.in4
3 files changed, 31 insertions, 4 deletions
diff --git a/pkg/deb/debian.module/unit.example-jsc18-config b/pkg/deb/debian.module/unit.example-jsc18-config
new file mode 100644
index 00000000..08f9f596
--- /dev/null
+++ b/pkg/deb/debian.module/unit.example-jsc18-config
@@ -0,0 +1,15 @@
+{
+ "applications": {
+ "example_java18": {
+ "processes": 1,
+ "type": "java 18",
+ "webapp": "/usr/share/doc/unit-jsc18/examples/jsc-app"
+ }
+ },
+
+ "listeners": {
+ "*:8800": {
+ "pass": "applications/example_java18"
+ }
+ }
+}
diff --git a/pkg/deb/debian.module/unit.example-python3.10-config b/pkg/deb/debian.module/unit.example-python3.10-config
new file mode 100644
index 00000000..eaeb6103
--- /dev/null
+++ b/pkg/deb/debian.module/unit.example-python3.10-config
@@ -0,0 +1,16 @@
+{
+ "applications": {
+ "example_python": {
+ "type": "python 3.10",
+ "processes": 2,
+ "path": "/usr/share/doc/unit-python3.10/examples/python-app",
+ "module": "wsgi"
+ }
+ },
+
+ "listeners": {
+ "*:8400": {
+ "pass": "applications/example_python"
+ }
+ }
+}
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index c7a56b6b..3f1f9db8 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -99,11 +99,7 @@ install: build do.tests
dh_testroot
dh_prep
dh_installdirs
-ifeq ($(CODENAME), xenial)
- dh_installinit
-else
dh_installsystemd
-endif
dh_installlogrotate
cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR) make install
cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR_dev) make libunit-install