summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian
diff options
context:
space:
mode:
authorKonstantin Pavlov <thresh@nginx.com>2022-12-15 08:17:39 -0800
committerKonstantin Pavlov <thresh@nginx.com>2022-12-15 08:17:39 -0800
commite22669f2728814aba82da14702d18bfa9685311e (patch)
treec9c9471dab359e8e33fca24c5d4f035ab5b278db /pkg/deb/debian
parenta1d28488f9df8e28ee25ea438c275b96b9afe5b6 (diff)
parent4409a10ff0bd6bb45fb88716bd383cd867958a8a (diff)
downloadunit-e22669f2728814aba82da14702d18bfa9685311e.tar.gz
unit-e22669f2728814aba82da14702d18bfa9685311e.tar.bz2
Merged with the default branch.
Diffstat (limited to '')
-rw-r--r--pkg/deb/debian.module/control.in2
-rw-r--r--pkg/deb/debian.module/unit.example-jsc19-config15
-rw-r--r--pkg/deb/debian/control.in4
-rw-r--r--pkg/deb/debian/rules.in9
4 files changed, 27 insertions, 3 deletions
diff --git a/pkg/deb/debian.module/control.in b/pkg/deb/debian.module/control.in
index f5ce8ae4..f82362d1 100644
--- a/pkg/deb/debian.module/control.in
+++ b/pkg/deb/debian.module/control.in
@@ -14,7 +14,7 @@ Section: admin
Architecture: any
Depends: lsb-base,
${misc:Depends}, ${shlibs:Depends},
- unit (= %%UNIT_VERSION%%-%%UNIT_RELEASE%%~%%CODENAME%%)%%MODULE_DEPENDS%%
+ unit-r%%UNIT_VERSION%%%%MODULE_DEPENDS%%
Description: %%SUMMARY%%
NGINX Unit is a runtime and delivery environment for modern distributed
applications. It runs the application code in multiple languages
diff --git a/pkg/deb/debian.module/unit.example-jsc19-config b/pkg/deb/debian.module/unit.example-jsc19-config
new file mode 100644
index 00000000..106b694b
--- /dev/null
+++ b/pkg/deb/debian.module/unit.example-jsc19-config
@@ -0,0 +1,15 @@
+{
+ "applications": {
+ "example_java19": {
+ "processes": 1,
+ "type": "java 19",
+ "webapp": "/usr/share/doc/unit-jsc19/examples/jsc-app"
+ }
+ },
+
+ "listeners": {
+ "*:8800": {
+ "pass": "applications/example_java19"
+ }
+ }
+}
diff --git a/pkg/deb/debian/control.in b/pkg/deb/debian/control.in
index 691bafed..579f41e3 100644
--- a/pkg/deb/debian/control.in
+++ b/pkg/deb/debian/control.in
@@ -5,7 +5,8 @@ Maintainer: %%PACKAGE_VENDOR%%
Build-Depends: debhelper (>= 11),
linux-libc-dev,
libssl-dev,
- libpcre2-dev
+ libpcre2-dev,
+ pkg-config
Standards-Version: 4.1.4
Homepage: https://unit.nginx.org
@@ -14,6 +15,7 @@ Section: admin
Architecture: any
Depends: lsb-base,
${misc:Depends}, ${shlibs:Depends}
+Provides: unit-r%%UNIT_VERSION%%
Description: NGINX Unit
NGINX Unit is a runtime and delivery environment for modern distributed
applications. It runs the application code in multiple languages
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index d2e34796..23812926 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -20,7 +20,12 @@ BASEDIR = $(CURDIR)
DOTESTS = 0
-config.env.%:
+njs:
+ dh_testdir
+ cd pkg/contrib && make .njs
+ touch $@
+
+config.env.%: njs
dh_testdir
mkdir -p $(BUILDDIR_$*)
cp -Pa $(CURDIR)/auto $(BUILDDIR_$*)/
@@ -40,6 +45,7 @@ config.env.%:
configure.unit: config.env.unit
cd $(BUILDDIR_unit) && \
+ PKG_CONFIG_PATH=$(CURDIR)/pkg/contrib/njs/build \
CFLAGS= ./configure \
%%CONFIGURE_ARGS%% \
--modules=/usr/lib/unit/modules \
@@ -50,6 +56,7 @@ configure.unit: config.env.unit
configure.unit_debug: config.env.unit_debug
cd $(BUILDDIR_unit_debug) && \
+ PKG_CONFIG_PATH=$(CURDIR)/pkg/contrib/njs/build \
CFLAGS= ./configure \
%%CONFIGURE_ARGS%% \
--modules=/usr/lib/unit/debug-modules \