summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian
diff options
context:
space:
mode:
authorAndrei Belov <defan@nginx.com>2018-10-25 19:00:07 +0300
committerAndrei Belov <defan@nginx.com>2018-10-25 19:00:07 +0300
commitdc3e83f26ce9f92a157d4332c723d531ca411b80 (patch)
treea723f2ce7d8c91527fdfb94eeae708292a705417 /pkg/deb/debian
parent8b37c0c70a183f19f7f4245ce0825954d8dbcaf7 (diff)
parentfd99a738e586326ee5b40a6bc3d09c64b18f394a (diff)
downloadunit-dc3e83f26ce9f92a157d4332c723d531ca411b80.tar.gz
unit-dc3e83f26ce9f92a157d4332c723d531ca411b80.tar.bz2
Merged with the default branch.1.5-1
Diffstat (limited to '')
-rw-r--r--pkg/deb/debian.module/unit.example-go-config30
-rw-r--r--pkg/deb/debian.module/unit.example-go1.10-config30
-rw-r--r--pkg/deb/debian.module/unit.example-go1.7-config30
-rw-r--r--pkg/deb/debian.module/unit.example-go1.8-config30
-rw-r--r--pkg/deb/debian.module/unit.example-go1.9-config30
-rw-r--r--pkg/deb/debian/control8
-rw-r--r--pkg/deb/debian/rules.in8
-rw-r--r--pkg/deb/debian/unit.example.config102
8 files changed, 142 insertions, 126 deletions
diff --git a/pkg/deb/debian.module/unit.example-go-config b/pkg/deb/debian.module/unit.example-go-config
index 6ee4d001..079ce0b8 100644
--- a/pkg/deb/debian.module/unit.example-go-config
+++ b/pkg/deb/debian.module/unit.example-go-config
@@ -1,15 +1,15 @@
-{
- "applications": {
- "example_go": {
- "type": "go",
- "user": "nobody",
- "executable": "/tmp/go-app"
- }
- },
-
- "listeners": {
- "*:8500": {
- "application": "example_go"
- }
- }
-}
+{
+ "applications": {
+ "example_go": {
+ "type": "external",
+ "user": "nobody",
+ "executable": "/tmp/go-app"
+ }
+ },
+
+ "listeners": {
+ "*:8500": {
+ "application": "example_go"
+ }
+ }
+}
diff --git a/pkg/deb/debian.module/unit.example-go1.10-config b/pkg/deb/debian.module/unit.example-go1.10-config
index 68733256..29bb9059 100644
--- a/pkg/deb/debian.module/unit.example-go1.10-config
+++ b/pkg/deb/debian.module/unit.example-go1.10-config
@@ -1,15 +1,15 @@
-{
- "applications": {
- "example_go": {
- "type": "go",
- "user": "nobody",
- "executable": "/tmp/go1.10-app"
- }
- },
-
- "listeners": {
- "*:8500": {
- "application": "example_go"
- }
- }
-}
+{
+ "applications": {
+ "example_go": {
+ "type": "external",
+ "user": "nobody",
+ "executable": "/tmp/go1.10-app"
+ }
+ },
+
+ "listeners": {
+ "*:8500": {
+ "application": "example_go"
+ }
+ }
+}
diff --git a/pkg/deb/debian.module/unit.example-go1.7-config b/pkg/deb/debian.module/unit.example-go1.7-config
index 1b1943e0..bd98fe3a 100644
--- a/pkg/deb/debian.module/unit.example-go1.7-config
+++ b/pkg/deb/debian.module/unit.example-go1.7-config
@@ -1,15 +1,15 @@
-{
- "applications": {
- "example_go": {
- "type": "go",
- "user": "nobody",
- "executable": "/tmp/go1.7-app"
- }
- },
-
- "listeners": {
- "*:8500": {
- "application": "example_go"
- }
- }
-}
+{
+ "applications": {
+ "example_go": {
+ "type": "external",
+ "user": "nobody",
+ "executable": "/tmp/go1.7-app"
+ }
+ },
+
+ "listeners": {
+ "*:8500": {
+ "application": "example_go"
+ }
+ }
+}
diff --git a/pkg/deb/debian.module/unit.example-go1.8-config b/pkg/deb/debian.module/unit.example-go1.8-config
index 6cfa0cec..1c14ca25 100644
--- a/pkg/deb/debian.module/unit.example-go1.8-config
+++ b/pkg/deb/debian.module/unit.example-go1.8-config
@@ -1,15 +1,15 @@
-{
- "applications": {
- "example_go": {
- "type": "go",
- "user": "nobody",
- "executable": "/tmp/go1.8-app"
- }
- },
-
- "listeners": {
- "*:8500": {
- "application": "example_go"
- }
- }
-}
+{
+ "applications": {
+ "example_go": {
+ "type": "external",
+ "user": "nobody",
+ "executable": "/tmp/go1.8-app"
+ }
+ },
+
+ "listeners": {
+ "*:8500": {
+ "application": "example_go"
+ }
+ }
+}
diff --git a/pkg/deb/debian.module/unit.example-go1.9-config b/pkg/deb/debian.module/unit.example-go1.9-config
index 4074df3b..341894b7 100644
--- a/pkg/deb/debian.module/unit.example-go1.9-config
+++ b/pkg/deb/debian.module/unit.example-go1.9-config
@@ -1,15 +1,15 @@
-{
- "applications": {
- "example_go": {
- "type": "go",
- "user": "nobody",
- "executable": "/tmp/go1.9-app"
- }
- },
-
- "listeners": {
- "*:8500": {
- "application": "example_go"
- }
- }
-}
+{
+ "applications": {
+ "example_go": {
+ "type": "external",
+ "user": "nobody",
+ "executable": "/tmp/go1.9-app"
+ }
+ },
+
+ "listeners": {
+ "*:8500": {
+ "application": "example_go"
+ }
+ }
+}
diff --git a/pkg/deb/debian/control b/pkg/deb/debian/control
index e1b1bde8..c0873a1c 100644
--- a/pkg/deb/debian/control
+++ b/pkg/deb/debian/control
@@ -29,3 +29,11 @@ Depends: unit (= ${binary:Version}),
${misc:Depends}
Description: NGINX Unit (debug symbols)
This package contains the debugging symbols for NGINX Unit.
+
+Package: unit-dev
+Section: libdevel
+Priority: optional
+Architecture: any
+Depends: ${misc:Depends}
+Description: NGINX Unit (development files)
+ Library and include files required for NGINX Unit modules development.
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index a9f68189..7eab391d 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -9,9 +9,12 @@ export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed -pie
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
BUILDDIR_unit = $(CURDIR)/debian/build-unit
BUILDDIR_unit_debug = $(CURDIR)/debian/build-unit-debug
INSTALLDIR = $(CURDIR)/debian/unit
+INSTALLDIR_dev = $(CURDIR)/debian/unit-dev
BASEDIR = $(CURDIR)
DOTESTS = 0
@@ -30,6 +33,7 @@ configure.unit: config.env.unit
CFLAGS= ./configure \
%%CONFIGURE_ARGS%% \
--modules=/usr/lib/unit/modules \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
--cc-opt="$(CFLAGS)" \
--ld-opt="$(LDFLAGS)"
touch $@
@@ -39,6 +43,7 @@ configure.unit_debug: config.env.unit_debug
CFLAGS= ./configure \
%%CONFIGURE_ARGS%% \
--modules=/usr/lib/unit/debug-modules \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
--cc-opt="$(CFLAGS)" \
--ld-opt="$(LDFLAGS)" \
--debug
@@ -47,6 +52,7 @@ configure.unit_debug: config.env.unit_debug
build-arch.%: configure.%
dh_testdir
$(MAKE) -C $(BUILDDIR_$*)
+ $(MAKE) -C $(BUILDDIR_$*) build/libunit.a
ifeq ($(DOTESTS), 1)
$(MAKE) -C $(BUILDDIR_$*) tests
endif
@@ -86,7 +92,9 @@ install: build do.tests
dh_installinit
dh_installlogrotate
cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR) make install
+ cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR_dev) make libunit-install
install -m 755 $(BUILDDIR_unit_debug)/build/unitd $(INSTALLDIR)/usr/sbin/unitd-debug
+ install -m 644 $(BUILDDIR_unit_debug)/build/libunit.a $(INSTALLDIR_dev)/usr/lib/$(DEB_HOST_MULTIARCH)/libunit-debug.a
mkdir -p $(INSTALLDIR)/usr/share/doc/unit/examples
install -m 644 debian/unit.example.config $(INSTALLDIR)/usr/share/doc/unit/examples/example.config
install -m 644 CHANGES $(INSTALLDIR)/usr/share/doc/unit/
diff --git a/pkg/deb/debian/unit.example.config b/pkg/deb/debian/unit.example.config
index f3126457..8d86acbe 100644
--- a/pkg/deb/debian/unit.example.config
+++ b/pkg/deb/debian/unit.example.config
@@ -1,51 +1,51 @@
-{
- "applications": {
- "example_php": {
- "type": "php",
- "user": "nobody",
- "processes": 2,
- "root": "/usr/share/doc/unit/examples/php-app",
- "index": "index.php"
- },
-
- "example_python": {
- "type": "python",
- "user": "nobody",
- "processes": 2,
- "path": "/usr/share/doc/unit/examples/python-app",
- "module": "wsgi"
- },
-
- "example_go": {
- "type": "go",
- "user": "nobody",
- "executable": "/tmp/go-app"
- },
-
- "example_perl": {
- "type": "perl",
- "user": "nobody",
- "processes": 1,
- "working_directory": "/usr/share/doc/unit-perl/examples/perl-app",
- "script": "/usr/share/doc/unit-perl/examples/perl-app/index.pl"
- }
- },
-
- "listeners": {
- "*:8300": {
- "application": "example_php"
- },
-
- "*:8400": {
- "application": "example_python"
- },
-
- "*:8500": {
- "application": "example_go"
- },
-
- "*:8600": {
- "application": "example_perl"
- }
- }
-}
+{
+ "applications": {
+ "example_php": {
+ "type": "php",
+ "user": "nobody",
+ "processes": 2,
+ "root": "/usr/share/doc/unit/examples/php-app",
+ "index": "index.php"
+ },
+
+ "example_python": {
+ "type": "python",
+ "user": "nobody",
+ "processes": 2,
+ "path": "/usr/share/doc/unit/examples/python-app",
+ "module": "wsgi"
+ },
+
+ "example_go": {
+ "type": "external",
+ "user": "nobody",
+ "executable": "/tmp/go-app"
+ },
+
+ "example_perl": {
+ "type": "perl",
+ "user": "nobody",
+ "processes": 1,
+ "working_directory": "/usr/share/doc/unit-perl/examples/perl-app",
+ "script": "/usr/share/doc/unit-perl/examples/perl-app/index.pl"
+ }
+ },
+
+ "listeners": {
+ "*:8300": {
+ "application": "example_php"
+ },
+
+ "*:8400": {
+ "application": "example_python"
+ },
+
+ "*:8500": {
+ "application": "example_go"
+ },
+
+ "*:8600": {
+ "application": "example_perl"
+ }
+ }
+}