summaryrefslogtreecommitdiffhomepage
path: root/src/wasm-wasi-component/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Clayton <a.clayton@nginx.com>2024-11-06 22:04:36 +0000
committerAndrew Clayton <a.clayton@nginx.com>2024-11-07 16:23:37 +0000
commite6519b9d97c5ad1de91901269cfefc1fc26b8e35 (patch)
tree52719f5e827c117ebd08f9e30738e9a4dc6769cd /src/wasm-wasi-component/Cargo.toml
parent158322ec9b7d2591c33102079c72e9720421f512 (diff)
downloadunit-e6519b9d97c5ad1de91901269cfefc1fc26b8e35.tar.gz
unit-e6519b9d97c5ad1de91901269cfefc1fc26b8e35.tar.bz2
wasm-wc: Update to wasmtime v26.0.1
This fixes an issue we had with wasm-wasi-component failing to load components with 2024/11/06 21:08:50 [alert] 107196#107196 failed to create initial state Caused by: 0: failed to compile component 1: WebAssembly translation error 2: Invalid input WebAssembly code at offset 15936: zero byte expected Which was a symptom of <https://github.com/bytecodealliance/wasmtime/issues/9130> Closes: https://github.com/nginx/unit/issues/1477 Signed-off-by: Andrew Clayton <a.clayton@nginx.com>
Diffstat (limited to 'src/wasm-wasi-component/Cargo.toml')
-rw-r--r--src/wasm-wasi-component/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/wasm-wasi-component/Cargo.toml b/src/wasm-wasi-component/Cargo.toml
index 46008305..c2874f44 100644
--- a/src/wasm-wasi-component/Cargo.toml
+++ b/src/wasm-wasi-component/Cargo.toml
@@ -17,10 +17,10 @@ http-body = { version = "1.0.0", default-features = false }
http-body-util = "0.1.0"
hyper = "1.4.1"
tokio = { version = "1.33.0", default-features = false }
-wasi-common = "24.0.0"
-wasmtime = { version = "24.0.1", default-features = false, features = ['component-model', 'cranelift'] }
-wasmtime-wasi = "24.0.0"
-wasmtime-wasi-http = "24.0.0"
+wasi-common = "26.0.1"
+wasmtime = { version = "26.0.1", default-features = false, features = ['component-model', 'cranelift'] }
+wasmtime-wasi = "26.0.1"
+wasmtime-wasi-http = "26.0.1"
[build-dependencies]
bindgen = "0.68.1"