summaryrefslogtreecommitdiffhomepage
path: root/test/wasm_component/hello_world/Cargo.toml
diff options
context:
space:
mode:
authorAndrei Zeliankou <zelenkov@nginx.com>2024-05-17 17:42:11 +0100
committerAva Hahn <110854134+avahahn@users.noreply.github.com>2024-08-20 11:38:51 -0700
commitcad6aed526b38d52f13266120f9a4381f9a22cad (patch)
tree8108d85b8c56f01504fdf329de787b56c5b7d0a8 /test/wasm_component/hello_world/Cargo.toml
parent593564fdd10da2bf4e76587a0482af72a9f1461b (diff)
downloadunit-cad6aed526b38d52f13266120f9a4381f9a22cad.tar.gz
unit-cad6aed526b38d52f13266120f9a4381f9a22cad.tar.bz2
Tests: initial "wasm-wasi-component" test
Diffstat (limited to '')
-rw-r--r--test/wasm_component/hello_world/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/test/wasm_component/hello_world/Cargo.toml b/test/wasm_component/hello_world/Cargo.toml
new file mode 100644
index 00000000..a87fbeb5
--- /dev/null
+++ b/test/wasm_component/hello_world/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "test-wasi-component"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+bitflags = "2.4.2"
+wit-bindgen-rt = "0.21.0"
+wasi = "0.13.0"
+
+[lib]
+crate-type = ["cdylib"]
+
+[package.metadata.component]
+package = "component:test-wasi-component"
+proxy = true
+
+[package.metadata.component.dependencies]