summaryrefslogtreecommitdiffhomepage
path: root/tools/unitctl/unit-client-rs/Cargo.toml
diff options
context:
space:
mode:
authorAva Hahn <a.hahn@f5.com>2024-05-06 12:28:40 -0700
committeravahahn <110854134+avahahn@users.noreply.github.com>2024-05-08 13:30:08 -0700
commitcc9eb8e756e84cd3fd59baf5b80efab0ffd5757d (patch)
tree23b42d96a10774ef949367fc8393d3c106aafc87 /tools/unitctl/unit-client-rs/Cargo.toml
parent6ad1fa342813f2c9f00813108c3f2eec8824fd6f (diff)
downloadunit-cc9eb8e756e84cd3fd59baf5b80efab0ffd5757d.tar.gz
unit-cc9eb8e756e84cd3fd59baf5b80efab0ffd5757d.tar.bz2
tools/unitctl: enable passing IP addresses to the 'instances new' command
* use path seperator constant from rust std package * pass a ControlSocket into deploy_new_container instead of a string * parse and validate a ControlSocket from argument to instances new * conditionally mount control socket only if its a unix socket * use create_image in a way that actually pulls nonpresent images * possibly override container command if TCP socket passed in * handle more weird error cases * add a ton of validation cases in the CLI command handler * add a nice little progress bar :) Signed-off-by: Ava Hahn <a.hahn@f5.com>
Diffstat (limited to 'tools/unitctl/unit-client-rs/Cargo.toml')
-rw-r--r--tools/unitctl/unit-client-rs/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/unitctl/unit-client-rs/Cargo.toml b/tools/unitctl/unit-client-rs/Cargo.toml
index 3e48ee23..b7b8b496 100644
--- a/tools/unitctl/unit-client-rs/Cargo.toml
+++ b/tools/unitctl/unit-client-rs/Cargo.toml
@@ -29,6 +29,7 @@ unit-openapi = { path = "../unit-openapi" }
rustls = "0.23.5"
bollard = "0.16.1"
regex = "1.10.4"
+pbr = "1.1.1"
[dev-dependencies]
rand = "0.8.5"