summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian/rules.in
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/deb/debian/rules.in')
-rw-r--r--pkg/deb/debian/rules.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index 1e76830f..aa7921d1 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -10,6 +10,7 @@ DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+CODENAME := $(shell lsb_release -cs)
BUILDDIR_unit = $(CURDIR)/debian/build-unit
BUILDDIR_unit_debug = $(CURDIR)/debian/build-unit-debug
@@ -96,7 +97,11 @@ install: build do.tests
dh_testroot
dh_prep
dh_installdirs
+ifeq ($(CODENAME), xenial)
+ dh_installinit
+else
dh_installsystemd
+endif
dh_installlogrotate
cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR) make install
cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR_dev) make libunit-install