summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/deb/debian')
-rw-r--r--pkg/deb/debian/control8
-rw-r--r--pkg/deb/debian/rules.in8
-rw-r--r--pkg/deb/debian/unit.example.config102
3 files changed, 67 insertions, 51 deletions
diff --git a/pkg/deb/debian/control b/pkg/deb/debian/control
index e1b1bde8..c0873a1c 100644
--- a/pkg/deb/debian/control
+++ b/pkg/deb/debian/control
@@ -29,3 +29,11 @@ Depends: unit (= ${binary:Version}),
${misc:Depends}
Description: NGINX Unit (debug symbols)
This package contains the debugging symbols for NGINX Unit.
+
+Package: unit-dev
+Section: libdevel
+Priority: optional
+Architecture: any
+Depends: ${misc:Depends}
+Description: NGINX Unit (development files)
+ Library and include files required for NGINX Unit modules development.
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index a9f68189..7eab391d 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -9,9 +9,12 @@ export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed -pie
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
BUILDDIR_unit = $(CURDIR)/debian/build-unit
BUILDDIR_unit_debug = $(CURDIR)/debian/build-unit-debug
INSTALLDIR = $(CURDIR)/debian/unit
+INSTALLDIR_dev = $(CURDIR)/debian/unit-dev
BASEDIR = $(CURDIR)
DOTESTS = 0
@@ -30,6 +33,7 @@ configure.unit: config.env.unit
CFLAGS= ./configure \
%%CONFIGURE_ARGS%% \
--modules=/usr/lib/unit/modules \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
--cc-opt="$(CFLAGS)" \
--ld-opt="$(LDFLAGS)"
touch $@
@@ -39,6 +43,7 @@ configure.unit_debug: config.env.unit_debug
CFLAGS= ./configure \
%%CONFIGURE_ARGS%% \
--modules=/usr/lib/unit/debug-modules \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
--cc-opt="$(CFLAGS)" \
--ld-opt="$(LDFLAGS)" \
--debug
@@ -47,6 +52,7 @@ configure.unit_debug: config.env.unit_debug
build-arch.%: configure.%
dh_testdir
$(MAKE) -C $(BUILDDIR_$*)
+ $(MAKE) -C $(BUILDDIR_$*) build/libunit.a
ifeq ($(DOTESTS), 1)
$(MAKE) -C $(BUILDDIR_$*) tests
endif
@@ -86,7 +92,9 @@ install: build do.tests
dh_installinit
dh_installlogrotate
cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR) make install
+ cd $(BUILDDIR_unit) && DESTDIR=$(INSTALLDIR_dev) make libunit-install
install -m 755 $(BUILDDIR_unit_debug)/build/unitd $(INSTALLDIR)/usr/sbin/unitd-debug
+ install -m 644 $(BUILDDIR_unit_debug)/build/libunit.a $(INSTALLDIR_dev)/usr/lib/$(DEB_HOST_MULTIARCH)/libunit-debug.a
mkdir -p $(INSTALLDIR)/usr/share/doc/unit/examples
install -m 644 debian/unit.example.config $(INSTALLDIR)/usr/share/doc/unit/examples/example.config
install -m 644 CHANGES $(INSTALLDIR)/usr/share/doc/unit/
diff --git a/pkg/deb/debian/unit.example.config b/pkg/deb/debian/unit.example.config
index f3126457..8d86acbe 100644
--- a/pkg/deb/debian/unit.example.config
+++ b/pkg/deb/debian/unit.example.config
@@ -1,51 +1,51 @@
-{
- "applications": {
- "example_php": {
- "type": "php",
- "user": "nobody",
- "processes": 2,
- "root": "/usr/share/doc/unit/examples/php-app",
- "index": "index.php"
- },
-
- "example_python": {
- "type": "python",
- "user": "nobody",
- "processes": 2,
- "path": "/usr/share/doc/unit/examples/python-app",
- "module": "wsgi"
- },
-
- "example_go": {
- "type": "go",
- "user": "nobody",
- "executable": "/tmp/go-app"
- },
-
- "example_perl": {
- "type": "perl",
- "user": "nobody",
- "processes": 1,
- "working_directory": "/usr/share/doc/unit-perl/examples/perl-app",
- "script": "/usr/share/doc/unit-perl/examples/perl-app/index.pl"
- }
- },
-
- "listeners": {
- "*:8300": {
- "application": "example_php"
- },
-
- "*:8400": {
- "application": "example_python"
- },
-
- "*:8500": {
- "application": "example_go"
- },
-
- "*:8600": {
- "application": "example_perl"
- }
- }
-}
+{
+ "applications": {
+ "example_php": {
+ "type": "php",
+ "user": "nobody",
+ "processes": 2,
+ "root": "/usr/share/doc/unit/examples/php-app",
+ "index": "index.php"
+ },
+
+ "example_python": {
+ "type": "python",
+ "user": "nobody",
+ "processes": 2,
+ "path": "/usr/share/doc/unit/examples/python-app",
+ "module": "wsgi"
+ },
+
+ "example_go": {
+ "type": "external",
+ "user": "nobody",
+ "executable": "/tmp/go-app"
+ },
+
+ "example_perl": {
+ "type": "perl",
+ "user": "nobody",
+ "processes": 1,
+ "working_directory": "/usr/share/doc/unit-perl/examples/perl-app",
+ "script": "/usr/share/doc/unit-perl/examples/perl-app/index.pl"
+ }
+ },
+
+ "listeners": {
+ "*:8300": {
+ "application": "example_php"
+ },
+
+ "*:8400": {
+ "application": "example_python"
+ },
+
+ "*:8500": {
+ "application": "example_go"
+ },
+
+ "*:8600": {
+ "application": "example_perl"
+ }
+ }
+}