summaryrefslogtreecommitdiffhomepage
path: root/src/wasm-wasi-component/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/wasm-wasi-component/Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/wasm-wasi-component/Cargo.toml b/src/wasm-wasi-component/Cargo.toml
index feb7f53c..bc325826 100644
--- a/src/wasm-wasi-component/Cargo.toml
+++ b/src/wasm-wasi-component/Cargo.toml
@@ -10,14 +10,17 @@ crate-type = ["cdylib"]
[dependencies]
anyhow = "1.0.75"
bytes = "1.5.0"
+futures = "0.3.30"
futures-util = { version = "0.3.29", default-features = false }
http = "1.0.0"
http-body = { version = "1.0.0", default-features = false }
http-body-util = "0.1.0"
+hyper = "1.4.1"
tokio = { version = "1.33.0", default-features = false }
-wasmtime = { version = "17.0.0", default-features = false, features = ['component-model', 'cranelift'] }
-wasmtime-wasi = "17.0.0"
-wasmtime-wasi-http = "17.0.0"
+wasi-common = "24.0.0"
+wasmtime = { version = "24.0.0", default-features = false, features = ['component-model', 'cranelift'] }
+wasmtime-wasi = "24.0.0"
+wasmtime-wasi-http = "24.0.0"
[build-dependencies]
bindgen = "0.68.1"