summaryrefslogtreecommitdiffhomepage
path: root/src/wasm-wasi-component/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/wasm-wasi-component/Cargo.toml')
-rw-r--r--src/wasm-wasi-component/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/wasm-wasi-component/Cargo.toml b/src/wasm-wasi-component/Cargo.toml
new file mode 100644
index 00000000..8f42d128
--- /dev/null
+++ b/src/wasm-wasi-component/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "wasm-wasi-component"
+version = "0.1.0"
+edition = "2021"
+publish = false
+
+[lib]
+crate-type = ["cdylib"]
+
+[dependencies]
+anyhow = "1.0.75"
+bytes = "1.5.0"
+futures-util = { version = "0.3.29", default-features = false }
+http = "0.2.9"
+http-body = { version = "1.0.0-rc.2", default-features = false }
+http-body-util = "0.1.0-rc.2"
+tokio = { version = "1.33.0", default-features = false }
+wasmtime = "14.0.2"
+wasmtime-wasi = "14.0.2"
+wasmtime-wasi-http = "14.0.2"
+
+[build-dependencies]
+bindgen = "0.68.1"
+cc = "1.0.83"
+
+[profile.dev]
+panic = 'abort'
+
+[profile.release]
+panic = 'abort'