summaryrefslogtreecommitdiffhomepage
path: root/src/wasm-wasi-component/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/wasm-wasi-component/Cargo.toml')
-rw-r--r--src/wasm-wasi-component/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/wasm-wasi-component/Cargo.toml b/src/wasm-wasi-component/Cargo.toml
index 8f42d128..feb7f53c 100644
--- a/src/wasm-wasi-component/Cargo.toml
+++ b/src/wasm-wasi-component/Cargo.toml
@@ -11,13 +11,13 @@ crate-type = ["cdylib"]
anyhow = "1.0.75"
bytes = "1.5.0"
futures-util = { version = "0.3.29", default-features = false }
-http = "0.2.9"
-http-body = { version = "1.0.0-rc.2", default-features = false }
-http-body-util = "0.1.0-rc.2"
+http = "1.0.0"
+http-body = { version = "1.0.0", default-features = false }
+http-body-util = "0.1.0"
tokio = { version = "1.33.0", default-features = false }
-wasmtime = "14.0.2"
-wasmtime-wasi = "14.0.2"
-wasmtime-wasi-http = "14.0.2"
+wasmtime = { version = "17.0.0", default-features = false, features = ['component-model', 'cranelift'] }
+wasmtime-wasi = "17.0.0"
+wasmtime-wasi-http = "17.0.0"
[build-dependencies]
bindgen = "0.68.1"