summaryrefslogtreecommitdiffhomepage
path: root/tools/unitctl/unit-openapi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tools/unitctl/unit-openapi/Cargo.toml')
-rw-r--r--tools/unitctl/unit-openapi/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/unitctl/unit-openapi/Cargo.toml b/tools/unitctl/unit-openapi/Cargo.toml
new file mode 100644
index 00000000..12435985
--- /dev/null
+++ b/tools/unitctl/unit-openapi/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "unit-openapi"
+version = "0.4.0-beta"
+authors = ["unit-owner@nginx.org"]
+description = "NGINX Unit is a lightweight and versatile application runtime that provides the essential components for your web application as a single open-source server: running application code, serving static assets, handling TLS and request routing. **Important**: Unit's API is designed to expose any part of its configuration as an addressable endpoint. Suppose a JSON object is stored at `/config/listeners/`: ```json { \"*:8080\": { \"pass\": \"applications/wp_emea_dev\" } } ``` Here, `/config/listeners/_*:8080` and `/config/listeners/_*:8080/pass` are also endpoints. Generally, object options are addressable by their names, array items—by their indexes (`/array/0/`). **Note**: By default, Unit is configured through a UNIX domain socket. To use this specification with OpenAPI tools interactively, [start](https://unit.nginx.org/howto/source/#source-startup) Unit with a TCP port as the control socket."
+license = "Apache 2.0"
+edition = "2018"
+
+[dependencies]
+serde = "1.0"
+serde_derive = "1.0"
+serde_json = "1.0"
+url = "2.2"
+hyper = { version = "0.14" }
+http = "0.2"
+base64 = "0.21"
+futures = "0.3"