summaryrefslogtreecommitdiff
path: root/rust/hello_world/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Clayton <a.clayton@nginx.com>2023-10-25 19:41:47 +0100
committerAndrew Clayton <a.clayton@nginx.com>2023-10-25 19:57:13 +0100
commit3aed80812e105cd99c43f11023012608aecd9f4a (patch)
treeef078ea7efe8f5024294cb698d6fb47be2891c25 /rust/hello_world/Cargo.toml
parent510d3becc7592405f02e90f5aa43740c53f7deeb (diff)
downloadproject_blackbird-3aed80812e105cd99c43f11023012608aecd9f4a.tar.gz
project_blackbird-3aed80812e105cd99c43f11023012608aecd9f4a.tar.bz2
Add a component model example
This adds the 'Hello World' example from here[0]. The runtime is in Rust and the component is in C. This requires some new tools - https://github.com/bytecodealliance/wit-bindgen - https://github.com/bytecodealliance/wasm-tools You can use the pre-built packages, once downloaded and untar'd, edit rust/hello_world/component/Makefile and adjust the paths for the above tools. To build the component with make you may need to specify where the WASI sysroot is $ make WASI_SYSROOT=/path/to/wasi-sysroot [0]: <https://docs.rs/wasmtime/latest/wasmtime/component/macro.bindgen.html> Signed-off-by: Andrew Clayton <a.clayton@nginx.com>
Diffstat (limited to 'rust/hello_world/Cargo.toml')
-rw-r--r--rust/hello_world/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/rust/hello_world/Cargo.toml b/rust/hello_world/Cargo.toml
new file mode 100644
index 0000000..7051e1b
--- /dev/null
+++ b/rust/hello_world/Cargo.toml
@@ -0,0 +1,10 @@
+[package]
+name = "hello_world"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+wasmtime = "14.0.1"
+wasmtime-wasi = "14.0.1"