summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian/rules.in
diff options
context:
space:
mode:
authorKonstantin Pavlov <thresh@nginx.com>2023-08-31 09:41:46 -0700
committerKonstantin Pavlov <thresh@nginx.com>2023-08-31 09:41:46 -0700
commitc45c8919c7232eb20023484f6d1fc9f1f50395d8 (patch)
treecc12eb307c1611494948645e4b487fa06495c3d2 /pkg/deb/debian/rules.in
parent88c90e1c351ab8c5bd487a5cd4b735014b08e271 (diff)
parent9b22b6957bc87b3df002d0bc691fdae6a20abdac (diff)
downloadunit-1.31.0-1.tar.gz
unit-1.31.0-1.tar.bz2
Merged with the default branch.1.31.0-1
Diffstat (limited to 'pkg/deb/debian/rules.in')
-rw-r--r--pkg/deb/debian/rules.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index 0d7cf830..55a4ebec 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -25,6 +25,11 @@ njs:
cd pkg/contrib && make .njs
touch $@
+libunit-wasm:
+ dh_testdir
+ cd pkg/contrib && make .libunit-wasm
+ touch $@
+
config.env.%: njs
dh_testdir
mkdir -p $(BUILDDIR_$*)
@@ -92,7 +97,7 @@ build-arch: build-arch.unit build-arch.unit_debug
dh_testdir
touch $@
-build: build-arch build-indep
+build: build-arch build-indep libunit-wasm
dh_testdir
touch $@
@@ -123,6 +128,9 @@ install: build do.tests
install -m 644 README.md $(INSTALLDIR)/usr/share/doc/unit/
install -m 644 CONTRIBUTING.md $(INSTALLDIR)/usr/share/doc/unit/
install -m 644 NOTICE $(INSTALLDIR)/usr/share/doc/unit/
+ mkdir -p $(INSTALLDIR_dev)/usr/include/unit
+ install -m644 $(CURDIR)/pkg/contrib/libunit-wasm/src/c/libunit-wasm.a $(INSTALLDIR_dev)/usr/lib/$(DEB_HOST_MULTIARCH)/libunit-wasm.a
+ install -m644 $(CURDIR)/pkg/contrib/libunit-wasm/src/c/include/unit/unit-wasm.h $(INSTALLDIR_dev)/usr/include/unit/
binary-indep: build install
dh_testdir