summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian
diff options
context:
space:
mode:
authorKonstantin Pavlov <thresh@nginx.com>2023-08-31 09:41:46 -0700
committerKonstantin Pavlov <thresh@nginx.com>2023-08-31 09:41:46 -0700
commitc45c8919c7232eb20023484f6d1fc9f1f50395d8 (patch)
treecc12eb307c1611494948645e4b487fa06495c3d2 /pkg/deb/debian
parent88c90e1c351ab8c5bd487a5cd4b735014b08e271 (diff)
parent9b22b6957bc87b3df002d0bc691fdae6a20abdac (diff)
downloadunit-c45c8919c7232eb20023484f6d1fc9f1f50395d8.tar.gz
unit-c45c8919c7232eb20023484f6d1fc9f1f50395d8.tar.bz2
Merged with the default branch.1.31.0-1
Diffstat (limited to 'pkg/deb/debian')
-rw-r--r--pkg/deb/debian/control.in4
-rw-r--r--pkg/deb/debian/copyright11
-rw-r--r--pkg/deb/debian/dirs1
-rw-r--r--pkg/deb/debian/rules.in10
4 files changed, 20 insertions, 6 deletions
diff --git a/pkg/deb/debian/control.in b/pkg/deb/debian/control.in
index 579f41e3..bc757233 100644
--- a/pkg/deb/debian/control.in
+++ b/pkg/deb/debian/control.in
@@ -6,7 +6,9 @@ Build-Depends: debhelper (>= 11),
linux-libc-dev,
libssl-dev,
libpcre2-dev,
- pkg-config
+ pkg-config,
+ clang,
+ llvm
Standards-Version: 4.1.4
Homepage: https://unit.nginx.org
diff --git a/pkg/deb/debian/copyright b/pkg/deb/debian/copyright
index 487c92c5..692ae2e0 100644
--- a/pkg/deb/debian/copyright
+++ b/pkg/deb/debian/copyright
@@ -1,12 +1,15 @@
NGINX Unit.
- Copyright 2017-2022 NGINX, Inc.
+ Copyright 2017-2023 NGINX, Inc.
+ Copyright 2017-2023 Andrei Zeliankou
+ Copyright 2018-2023 Konstantin Pavlov
+ Copyright 2021-2023 Zhidao Hong
+ Copyright 2021-2023 Alejandro Colomar
+ Copyright 2022-2023 Andrew Clayton
+ Copyright 2022-2023 Liam Crilly
Copyright 2017-2022 Valentin V. Bartenev
Copyright 2017-2022 Max Romanov
- Copyright 2017-2022 Andrei Zeliankou
- Copyright 2018-2022 Konstantin Pavlov
- Copyright 2021-2022 Zhidao Hong
Copyright 2021-2022 Oisín Canty
Copyright 2017-2021 Igor Sysoev
Copyright 2017-2021 Andrei Belov
diff --git a/pkg/deb/debian/dirs b/pkg/deb/debian/dirs
index 2568bac1..552cdf7c 100644
--- a/pkg/deb/debian/dirs
+++ b/pkg/deb/debian/dirs
@@ -1,4 +1,5 @@
usr/bin
usr/sbin
usr/lib/unit
+usr/include/unit
var/lib/unit
diff --git a/pkg/deb/debian/rules.in b/pkg/deb/debian/rules.in
index 0d7cf830..55a4ebec 100644
--- a/pkg/deb/debian/rules.in
+++ b/pkg/deb/debian/rules.in
@@ -25,6 +25,11 @@ njs:
cd pkg/contrib && make .njs
touch $@
+libunit-wasm:
+ dh_testdir
+ cd pkg/contrib && make .libunit-wasm
+ touch $@
+
config.env.%: njs
dh_testdir
mkdir -p $(BUILDDIR_$*)
@@ -92,7 +97,7 @@ build-arch: build-arch.unit build-arch.unit_debug
dh_testdir
touch $@
-build: build-arch build-indep
+build: build-arch build-indep libunit-wasm
dh_testdir
touch $@
@@ -123,6 +128,9 @@ install: build do.tests
install -m 644 README.md $(INSTALLDIR)/usr/share/doc/unit/
install -m 644 CONTRIBUTING.md $(INSTALLDIR)/usr/share/doc/unit/
install -m 644 NOTICE $(INSTALLDIR)/usr/share/doc/unit/
+ mkdir -p $(INSTALLDIR_dev)/usr/include/unit
+ install -m644 $(CURDIR)/pkg/contrib/libunit-wasm/src/c/libunit-wasm.a $(INSTALLDIR_dev)/usr/lib/$(DEB_HOST_MULTIARCH)/libunit-wasm.a
+ install -m644 $(CURDIR)/pkg/contrib/libunit-wasm/src/c/include/unit/unit-wasm.h $(INSTALLDIR_dev)/usr/include/unit/
binary-indep: build install
dh_testdir