summaryrefslogtreecommitdiffhomepage
path: root/pkg/deb/debian.module/rules.in
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/deb/debian.module/rules.in')
-rwxr-xr-xpkg/deb/debian.module/rules.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkg/deb/debian.module/rules.in b/pkg/deb/debian.module/rules.in
index 7814fbfd..8877ff23 100755
--- a/pkg/deb/debian.module/rules.in
+++ b/pkg/deb/debian.module/rules.in
@@ -3,8 +3,13 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
+include /usr/share/dpkg/vendor.mk
+ifeq ($(shell $(call dpkg_vendor_derives_from,ubuntu)),yes)
+export DEB_CFLAGS_MAINT_APPEND=-fPIC
+else
export DEB_CFLAGS_MAINT_APPEND=-Wp,-D_FORTIFY_SOURCE=2 -fPIC
+endif
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk